Mình xài router Mikrotik 750gr3 cho hệ thống mạng ở nhà hơn 5 năm nay, nhưng tới bây giờ mới biết cách bật FastTrack trên RouterOS. Có lần mình nâng gói cước cáp quang Viettel lên 1Gpbs, nhưng tốc độ Internet ở nhà chỉ lên được tối đa 250 Mbps. Lần đó cứ tưởng lỗi ở nhà mạng, hóa ra lỗi là do mình chưa cấu hình FastTrack trên router Mikrotik.

Kích hoạt FastTrack

Kích hoạt FastTrack trên RouterOS của Mikrotik chỉ bằng các dòng lệnh dưới đây. Mở Winbox, kết nối vào router, mở Terminal và nhập lệnh vào:

/ip firewall filter
add chain=forward action=fasttrack-connection connection-state=established,related \
  comment="fasttrack established/related"
add chain=forward action=accept connection-state=established,related \
  comment="accept established/related"Code language: Dockerfile (dockerfile)

Sau khi chạy, mở mục IP –> Firewall, trong mục Filter Rules sẽ thấy có thêm 3 dòng được bổ sung như hình.

Sau khi kích hoạt Fasttrack, tốc độ Internet đã được cải thiện rõ rệt, kéo lên được gần 400Mpbs (gói cước của mình là 250Mbps).

Khắc phục lỗi khi chạy WireGuard

Tuy nhiên, sau khi kích hoạt Fasttrack thì phần cấu hình định tuyến WireGuard không hoạt động ổn định, tốc độ mạng khi qua WireGuard cực kì ì ạch.

Để khắc phục lỗi này, mình sẽ tạo thêm các Filter Rules để loại bỏ 1 số IP trong mạng nhà không chạy qua FastTrack bằng lệnh sau:

/ip firewall filter
add action=accept chain=forward connection-state=established,related src-address=192.168.0.91
add action=accept chain=forward connection-state=established,related dst-address=192.168.0.91
add action=fasttrack-connection chain=forward connection-state=established,related hw-offload=no
add action=accept chain=forward connection-state=established,relatedCode language: Dockerfile (dockerfile)

Sau đó, vô mục Filter Rules, kéo 4 dòng mới vừa tạo lên trên cùng (chỉ nằm dưới mục 0-D-passthrough) như hình dưới.

Các lệnh này sẽ tạo ra các rule mới để chỉ định IP 192.168.0.91 đi theo kết nối bình thường, không đi qua FastTrack. Các IP khác còn lại trong mạng nội bộ đều sẽ đi qua FastTrack.

Cách này áp dụng được đối với mình vì IP 192.168.0.91 là IP duy nhất trong nhà mình thiết lập đi qua WireGuard bằng Mangle Rule (dùng cho TV LG để xem Netflix của Nhật). Do đó để tránh xung đột giữa FastTrack và Mangle Rule, mình loại bỏ IP này ra khỏi FastTrack.

Còn nếu muốn áp dụng cho toàn bộ IP trong nhà vừa dùng Mangle Rule và dùng FastTrack thì mình chưa biết làm sao. Bạn nào biết bí kíp thì chia sẻ giúp ở phần Bình luận bên dưới nhé.

Tham khảo: https://help.mikrotik.com/docs/display/ROS/Packet+Flow+in+RouterOS#PacketFlowinRouterOS-FastTrack

Nếu bài viết của mình mang đến thông tin, kiến thức hữu ích cho bạn, đừng ngại mời mình ly bia để có thêm động lực chia sẻ nhiều hơn nữa. Cám ơn bạn!

Lưu ý: Nếu bạn cần hỗ trợ kỹ thuật, vui lòng gửi câu hỏi trực tiếp ở phần Thảo luận bên dưới, mình sẽ trả lời sớm. Đừng vào hỏi trong fanpage Yêu Chạy Bộ, sẽ không có phản hồi đâu!

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *


3 Comments

  1. ad ơi nếu mình muốn loại bỏ 1 dãy IP hoặc một vài ip từ wireguard ra khỏi fastrack thì làm sao vậy, mình xài gần 3 năm rồi mới biết fastrack mà cài fastrack thì VPN ko dùng được hic hic.